import Foundation
let pattern = #"((20)?[012][0-9][ ,.,。、\/\--—年])?(0?[0-9]|1[012])[ ,.,。、\/\--—月](([012]?[0-9]|3[01])[ ,.,。、\/\--—号日](\s*[0-5]?[0-9]分([::]?[0-5]?[0-9]秒)?)?)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"2020年3月3日"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)