using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^Time: ([0-9:AMP\s]+)\sto ([0-9:AMP\s]+)";
string input = @"Time: 12:00 PM to 9:00 PM";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}