// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^Time: ([0-9:AMP\s]+)\sto ([0-9:AMP\s]+)").unwrap();
let string = "Time: 12:00 PM to 9:00 PM";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}