package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^Time: ([0-9:AMP\s]+)\sto ([0-9:AMP\s]+)`)
var str = `Time: 12:00 PM to 9:00 PM`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}