$re = '/^Time: ([0-9:AMP\s]+)\sto ([0-9:AMP\s]+)/m';
$str = 'Time: 12:00 PM to 9:00 PM';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);