const regex = /^Time: ([0-9:AMP\s]+)\sto ([0-9:AMP\s]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Time: ([0-9:AMP\\s]+)\\sto ([0-9:AMP\\s]+)', 'gm')
const str = `Time: 12:00 PM to 9:00 PM`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}