re = /^Time: ([0-9:AMP\s]+)\sto ([0-9:AMP\s]+)/m
str = 'Time: 12:00 PM to 9:00 PM'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end