#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\d*\.\d+|\d+)[MTBmtb]{0,1}\b"
Local $sString = "1234b" & @CRLF & _
"1234B" & @CRLF & _
".124b" & @CRLF & _
"0.123" & @CRLF & _
"1234bb" & @CRLF & _
"12345e"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")