re = /(?:\d*\.\d+|\d+)[MTBmtb]{0,1}\b/m
str = '1234b
1234B
.124b
0.123
1234bb
12345e'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end