const regex = /(?:\d*\.\d+|\d+)[MTBmtb]{0,1}\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\d*\\.\\d+|\\d+)[MTBmtb]{0,1}\\b', 'gm')
const str = `1234b
1234B
.124b
0.123
1234bb
12345e`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}