package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\d*\.\d+|\d+)[MTBmtb]{0,1}\b`)
var str = `1234b
1234B
.124b
0.123
1234bb
12345e`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}