// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\d*\.\d+|\d+)[MTBmtb]{0,1}\b").unwrap();
let string = "1234b
1234B
.124b
0.123
1234bb
12345e";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}