#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\D+\s+\D+)(?:\s+\D+)*$"
Local $sString = "Color" & @CRLF & _
"Color 1" & @CRLF & _
"Color 2" & @CRLF & _
"Color 3" & @CRLF & _
"Age Range" & @CRLF & _
"Age Range Minimum" & @CRLF & _
"Age Range Maximum" & @CRLF & _
"" & @CRLF & _
"Color" & @CRLF & _
"Color 1" & @CRLF & _
"Color 2" & @CRLF & _
"Color 3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")