import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\D+\\s+\\D+)(?:\\s+\\D+)*$";
final String string = "Color\n"
+ "Color 1\n"
+ "Color 2\n"
+ "Color 3\n"
+ "Age Range\n"
+ "Age Range Minimum\n"
+ "Age Range Maximum\n\n"
+ "Color\n"
+ "Color 1\n"
+ "Color 2\n"
+ "Color 3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}