// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:\D+\s+\D+)(?:\s+\D+)*$").unwrap();
let string = "Color
Color 1
Color 2
Color 3
Age Range
Age Range Minimum
Age Range Maximum
Color
Color 1
Color 2
Color 3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}