const regex = /^(?:\D+\s+\D+)(?:\s+\D+)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\D+\\s+\\D+)(?:\\s+\\D+)*$', 'gm')
const str = `Color
Color 1
Color 2
Color 3
Age Range
Age Range Minimum
Age Range Maximum
Color
Color 1
Color 2
Color 3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}