using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\D+\s+\D+)(?:\s+\D+)*$";
string input = @"Color
Color 1
Color 2
Color 3
Age Range
Age Range Minimum
Age Range Maximum
Color
Color 1
Color 2
Color 3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}