#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(S[0-9]+-[0-9]+-[0-9]+|S[0-9]+)"
Local $sString = "Samples" & @CRLF & _
"101003 W1D1 Pre" & @CRLF & _
"101003 W1D1 4H" & @CRLF & _
"101003 W1D2 Pre" & @CRLF & _
"101003 W2D1 Pre" & @CRLF & _
"101004 W1D1 Pre" & @CRLF & _
"101004 W1D1 4H" & @CRLF & _
"101004 W1D2 Pre" & @CRLF & _
"101004 W2D1 Pre" & @CRLF & _
"101005 W1D1 Pre" & @CRLF & _
"101005 W1D1 4H" & @CRLF & _
"101005 W1D2 Pre" & @CRLF & _
"101005 W2D1 Pre" & @CRLF & _
"101007 W1D1 Pre" & @CRLF & _
"101007 W1D1 4H" & @CRLF & _
"101007 W1D2 Pre" & @CRLF & _
"101007 W2D1 Pre" & @CRLF & _
"102001 W1D1 Pre" & @CRLF & _
"102001 W1D1 4H" & @CRLF & _
"102001 W1D2 Pre" & @CRLF & _
"102001 W2D1 Pre" & @CRLF & _
"102002 W1D1 Pre" & @CRLF & _
"102002 W1D1 4H" & @CRLF & _
"102002 W1D2 Pre" & @CRLF & _
"102002 W2D1 Pre" & @CRLF & _
"102005 W1D1 Pre" & @CRLF & _
"102005 W1D1 4H" & @CRLF & _
"102005 W1D2 Pre" & @CRLF & _
"102005 W2D1 Pre" & @CRLF & _
"104001 W1D1 Pre" & @CRLF & _
"104001 W1D1 4H" & @CRLF & _
"104001 W1D2 Pre" & @CRLF & _
"104001 W2D1 Pre" & @CRLF & _
"104002 W1D1 Pre" & @CRLF & _
"104002 W1D1 4H" & @CRLF & _
"104002 W1D2 Pre" & @CRLF & _
"104002 W2D1 Pre" & @CRLF & _
"104005 W1D1 Pre" & @CRLF & _
"104005 W1D1 4H" & @CRLF & _
"104005 W1D2 Pre" & @CRLF & _
"104005 W2D1 Pre" & @CRLF & _
"105001 W1D1 Pre" & @CRLF & _
"105001 W1D1 4H" & @CRLF & _
"105001 W1D2 Pre" & @CRLF & _
"105001 W2D1 Pre" & @CRLF & _
"105002 W1D1 Pre" & @CRLF & _
"105002 W1D1 4H" & @CRLF & _
"105002 W1D2 Pre" & @CRLF & _
"105002 W2D1 Pre" & @CRLF & _
"105005 W1D1 Pre" & @CRLF & _
"105005 W1D1 4H" & @CRLF & _
"105005 W1D2 Pre" & @CRLF & _
"105005 W2D1 Pre" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")