import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(S[0-9]+-[0-9]+-[0-9]+|S[0-9]+)";
final String string = "Samples\n"
+ "101003 W1D1 Pre\n"
+ "101003 W1D1 4H\n"
+ "101003 W1D2 Pre\n"
+ "101003 W2D1 Pre\n"
+ "101004 W1D1 Pre\n"
+ "101004 W1D1 4H\n"
+ "101004 W1D2 Pre\n"
+ "101004 W2D1 Pre\n"
+ "101005 W1D1 Pre\n"
+ "101005 W1D1 4H\n"
+ "101005 W1D2 Pre\n"
+ "101005 W2D1 Pre\n"
+ "101007 W1D1 Pre\n"
+ "101007 W1D1 4H\n"
+ "101007 W1D2 Pre\n"
+ "101007 W2D1 Pre\n"
+ "102001 W1D1 Pre\n"
+ "102001 W1D1 4H\n"
+ "102001 W1D2 Pre\n"
+ "102001 W2D1 Pre\n"
+ "102002 W1D1 Pre\n"
+ "102002 W1D1 4H\n"
+ "102002 W1D2 Pre\n"
+ "102002 W2D1 Pre\n"
+ "102005 W1D1 Pre\n"
+ "102005 W1D1 4H\n"
+ "102005 W1D2 Pre\n"
+ "102005 W2D1 Pre\n"
+ "104001 W1D1 Pre\n"
+ "104001 W1D1 4H\n"
+ "104001 W1D2 Pre\n"
+ "104001 W2D1 Pre\n"
+ "104002 W1D1 Pre\n"
+ "104002 W1D1 4H\n"
+ "104002 W1D2 Pre\n"
+ "104002 W2D1 Pre\n"
+ "104005 W1D1 Pre\n"
+ "104005 W1D1 4H\n"
+ "104005 W1D2 Pre\n"
+ "104005 W2D1 Pre\n"
+ "105001 W1D1 Pre\n"
+ "105001 W1D1 4H\n"
+ "105001 W1D2 Pre\n"
+ "105001 W2D1 Pre\n"
+ "105002 W1D1 Pre\n"
+ "105002 W1D1 4H\n"
+ "105002 W1D2 Pre\n"
+ "105002 W2D1 Pre\n"
+ "105005 W1D1 Pre\n"
+ "105005 W1D1 4H\n"
+ "105005 W1D2 Pre\n"
+ "105005 W2D1 Pre\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}