# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(S[0-9]+-[0-9]+-[0-9]+|S[0-9]+)"
test_str = ("Samples\n"
"101003 W1D1 Pre\n"
"101003 W1D1 4H\n"
"101003 W1D2 Pre\n"
"101003 W2D1 Pre\n"
"101004 W1D1 Pre\n"
"101004 W1D1 4H\n"
"101004 W1D2 Pre\n"
"101004 W2D1 Pre\n"
"101005 W1D1 Pre\n"
"101005 W1D1 4H\n"
"101005 W1D2 Pre\n"
"101005 W2D1 Pre\n"
"101007 W1D1 Pre\n"
"101007 W1D1 4H\n"
"101007 W1D2 Pre\n"
"101007 W2D1 Pre\n"
"102001 W1D1 Pre\n"
"102001 W1D1 4H\n"
"102001 W1D2 Pre\n"
"102001 W2D1 Pre\n"
"102002 W1D1 Pre\n"
"102002 W1D1 4H\n"
"102002 W1D2 Pre\n"
"102002 W2D1 Pre\n"
"102005 W1D1 Pre\n"
"102005 W1D1 4H\n"
"102005 W1D2 Pre\n"
"102005 W2D1 Pre\n"
"104001 W1D1 Pre\n"
"104001 W1D1 4H\n"
"104001 W1D2 Pre\n"
"104001 W2D1 Pre\n"
"104002 W1D1 Pre\n"
"104002 W1D1 4H\n"
"104002 W1D2 Pre\n"
"104002 W2D1 Pre\n"
"104005 W1D1 Pre\n"
"104005 W1D1 4H\n"
"104005 W1D2 Pre\n"
"104005 W2D1 Pre\n"
"105001 W1D1 Pre\n"
"105001 W1D1 4H\n"
"105001 W1D2 Pre\n"
"105001 W2D1 Pre\n"
"105002 W1D1 Pre\n"
"105002 W1D1 4H\n"
"105002 W1D2 Pre\n"
"105002 W2D1 Pre\n"
"105005 W1D1 Pre\n"
"105005 W1D1 4H\n"
"105005 W1D2 Pre\n"
"105005 W2D1 Pre\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.