using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(S[0-9]+-[0-9]+-[0-9]+|S[0-9]+)";
string input = @"Samples
101003 W1D1 Pre
101003 W1D1 4H
101003 W1D2 Pre
101003 W2D1 Pre
101004 W1D1 Pre
101004 W1D1 4H
101004 W1D2 Pre
101004 W2D1 Pre
101005 W1D1 Pre
101005 W1D1 4H
101005 W1D2 Pre
101005 W2D1 Pre
101007 W1D1 Pre
101007 W1D1 4H
101007 W1D2 Pre
101007 W2D1 Pre
102001 W1D1 Pre
102001 W1D1 4H
102001 W1D2 Pre
102001 W2D1 Pre
102002 W1D1 Pre
102002 W1D1 4H
102002 W1D2 Pre
102002 W2D1 Pre
102005 W1D1 Pre
102005 W1D1 4H
102005 W1D2 Pre
102005 W2D1 Pre
104001 W1D1 Pre
104001 W1D1 4H
104001 W1D2 Pre
104001 W2D1 Pre
104002 W1D1 Pre
104002 W1D1 4H
104002 W1D2 Pre
104002 W2D1 Pre
104005 W1D1 Pre
104005 W1D1 4H
104005 W1D2 Pre
104005 W2D1 Pre
105001 W1D1 Pre
105001 W1D1 4H
105001 W1D2 Pre
105001 W2D1 Pre
105002 W1D1 Pre
105002 W1D1 4H
105002 W1D2 Pre
105002 W2D1 Pre
105005 W1D1 Pre
105005 W1D1 4H
105005 W1D2 Pre
105005 W2D1 Pre
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}