package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(S[0-9]+-[0-9]+-[0-9]+|S[0-9]+)`)
var str = `Samples
101003 W1D1 Pre
101003 W1D1 4H
101003 W1D2 Pre
101003 W2D1 Pre
101004 W1D1 Pre
101004 W1D1 4H
101004 W1D2 Pre
101004 W2D1 Pre
101005 W1D1 Pre
101005 W1D1 4H
101005 W1D2 Pre
101005 W2D1 Pre
101007 W1D1 Pre
101007 W1D1 4H
101007 W1D2 Pre
101007 W2D1 Pre
102001 W1D1 Pre
102001 W1D1 4H
102001 W1D2 Pre
102001 W2D1 Pre
102002 W1D1 Pre
102002 W1D1 4H
102002 W1D2 Pre
102002 W2D1 Pre
102005 W1D1 Pre
102005 W1D1 4H
102005 W1D2 Pre
102005 W2D1 Pre
104001 W1D1 Pre
104001 W1D1 4H
104001 W1D2 Pre
104001 W2D1 Pre
104002 W1D1 Pre
104002 W1D1 4H
104002 W1D2 Pre
104002 W2D1 Pre
104005 W1D1 Pre
104005 W1D1 4H
104005 W1D2 Pre
104005 W2D1 Pre
105001 W1D1 Pre
105001 W1D1 4H
105001 W1D2 Pre
105001 W2D1 Pre
105002 W1D1 Pre
105002 W1D1 4H
105002 W1D2 Pre
105002 W2D1 Pre
105005 W1D1 Pre
105005 W1D1 4H
105005 W1D2 Pre
105005 W2D1 Pre
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}