// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(S[0-9]+-[0-9]+-[0-9]+|S[0-9]+)").unwrap();
let string = "Samples
101003 W1D1 Pre
101003 W1D1 4H
101003 W1D2 Pre
101003 W2D1 Pre
101004 W1D1 Pre
101004 W1D1 4H
101004 W1D2 Pre
101004 W2D1 Pre
101005 W1D1 Pre
101005 W1D1 4H
101005 W1D2 Pre
101005 W2D1 Pre
101007 W1D1 Pre
101007 W1D1 4H
101007 W1D2 Pre
101007 W2D1 Pre
102001 W1D1 Pre
102001 W1D1 4H
102001 W1D2 Pre
102001 W2D1 Pre
102002 W1D1 Pre
102002 W1D1 4H
102002 W1D2 Pre
102002 W2D1 Pre
102005 W1D1 Pre
102005 W1D1 4H
102005 W1D2 Pre
102005 W2D1 Pre
104001 W1D1 Pre
104001 W1D1 4H
104001 W1D2 Pre
104001 W2D1 Pre
104002 W1D1 Pre
104002 W1D1 4H
104002 W1D2 Pre
104002 W2D1 Pre
104005 W1D1 Pre
104005 W1D1 4H
104005 W1D2 Pre
104005 W2D1 Pre
105001 W1D1 Pre
105001 W1D1 4H
105001 W1D2 Pre
105001 W2D1 Pre
105002 W1D1 Pre
105002 W1D1 4H
105002 W1D2 Pre
105002 W2D1 Pre
105005 W1D1 Pre
105005 W1D1 4H
105005 W1D2 Pre
105005 W2D1 Pre
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}