using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\\{2,}\$[0-9.]+)|\$([^$\s]+)";
string input = @"test $test1 testagain$test2 testyetagain $test3 $test4$test5 \\$1.00 \\\\\\$1.00
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}