package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\\{2,}\$[0-9.]+)|\$([^$\s]+)`)
var str = `test $test1 testagain$test2 testyetagain $test3 $test4$test5 \\$1.00 \\\\\\$1.00
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}