const regex = /(?:\\{2,}\$[0-9.]+)|\$([^$\s]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\\\{2,}\\$[0-9.]+)|\\$([^$\\s]+)', 'g')
const str = `test \$test1 testagain\$test2 testyetagain \$test3 \$test4\$test5 \\\\\$1.00 \\\\\\\\\\\\\$1.00
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}