$re = '/(?:\\\\{2,}\$[0-9.]+)|\$([^$\s]+)/';
$str = 'test $test1 testagain$test2 testyetagain $test3 $test4$test5 \\\\$1.00 \\\\\\\\\\\\$1.00
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);