import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\\\{2,}\\$[0-9.]+)|\\$([^$\\s]+)";
final String string = "test $test1 testagain$test2 testyetagain $test3 $test4$test5 \\\\$1.00 \\\\\\\\\\\\$1.00\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}