re = /(?:\\{2,}\$[0-9.]+)|\$([^$\s]+)/
str = 'test $test1 testagain$test2 testyetagain $test3 $test4$test5 \\\\$1.00 \\\\\\\\\\\\$1.00
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end