package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([\w\S])+$`)
var str = `p3i9Tn29I3201u2NpNsN12CwVetj9CgLlOjWEsN/I/Sm9GqhUog78QTbB0eofucaNuDGkGwlSMr5rmuo
122435678998765445678
srdtfyguhijixtcyugyihuo
4s5d6f7g8h90c7vy8bu9nm7yg8hu9i
!@#$%ˆ&*()!@#$%ˆ&*<>?:"{}|\\/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}