// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([\w\S])+$").unwrap();
let string = "p3i9Tn29I3201u2NpNsN12CwVetj9CgLlOjWEsN/I/Sm9GqhUog78QTbB0eofucaNuDGkGwlSMr5rmuo
122435678998765445678
srdtfyguhijixtcyugyihuo
4s5d6f7g8h90c7vy8bu9nm7yg8hu9i
!@#$%ˆ&*()!@#$%ˆ&*<>?:\"{}|\\\\/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}