const regex = /^([\w\S])+$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\w\\S])+$', 'mg')
const str = `p3i9Tn29I3201u2NpNsN12CwVetj9CgLlOjWEsN/I/Sm9GqhUog78QTbB0eofucaNuDGkGwlSMr5rmuo
122435678998765445678
srdtfyguhijixtcyugyihuo
4s5d6f7g8h90c7vy8bu9nm7yg8hu9i
!@#\$%ˆ&*()!@#\$%ˆ&*<>?:"{}|\\\\/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}