import Foundation
let pattern = #"^([\w\S])+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
p3i9Tn29I3201u2NpNsN12CwVetj9CgLlOjWEsN/I/Sm9GqhUog78QTbB0eofucaNuDGkGwlSMr5rmuo
122435678998765445678
srdtfyguhijixtcyugyihuo
4s5d6f7g8h90c7vy8bu9nm7yg8hu9i
!@#$%ˆ&*()!@#$%ˆ&*<>?:"{}|\\/
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)