#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mx)(?:" & @CRLF & _
" (?:["“][^"”]*[.?!]["”])" & @CRLF & _
" |(?:(?:" & @CRLF & _
" ["“][^"”]*(?<![.?!])["”]" & @CRLF & _
" |[^".?!]+" & @CRLF & _
" )+)[.?!]["”]?" & @CRLF & _
")" & @CRLF & _
"\K\s*"
Local $sString = ""This is," she said, "a bad idea."" & @CRLF & _
"“Beer. Whatever you’ve got on draft is fine.” He handed my a bottle. I didn't want that." & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)