package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:
(?:["“][^"”]*[.?!]["”])
|(?:(?:
["“][^"”]*(?<![.?!])["”]
|[^".?!]+
)+)[.?!]["”]?
)
\K\s*`)
var str = `"This is," she said, "a bad idea."
“Beer. Whatever you’ve got on draft is fine.” He handed my a bottle. I didn't want that.
`
var substitution = "\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}