// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mx)(?:
(?:["“][^"”]*[.?!]["”])
|(?:(?:
["“][^"”]*(?<![.?!])["”]
|[^".?!]+
)+)[.?!]["”]?
)
\K\s*"#).unwrap();
let string = "\"This is,\" she said, \"a bad idea.\"
“Beer. Whatever you’ve got on draft is fine.” He handed my a bottle. I didn't want that.
";
let substitution = "\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}