const regex = /(?:
(?:["“][^"”]*[.?!]["”])
|(?:(?:
["“][^"”]*(?<![.?!])["”]
|[^".?!]+
)+)[.?!]["”]?
)
\K\s*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:
(?:["“][^"”]*[.?!]["”])
|(?:(?:
["“][^"”]*(?<![.?!])["”]
|[^".?!]+
)+)[.?!]["”]?
)
\\K\\s*', 'gm')
const str = `"This is," she said, "a bad idea."
“Beer. Whatever you’ve got on draft is fine.” He handed my a bottle. I didn't want that.
`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);