$re = '/(?:
(?:["“][^"”]*[.?!]["”])
|(?:(?:
["“][^"”]*(?<![.?!])["”]
|[^".?!]+
)+)[.?!]["”]?
)
\K\s*/mx';
$str = '"This is," she said, "a bad idea."
“Beer. Whatever you’ve got on draft is fine.” He handed my a bottle. I didn\'t want that.
';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;