import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\n"
+ " (?:[\"“][^\"”]*[.?!][\"”])\n"
+ " |(?:(?:\n"
+ " [\"“][^\"”]*(?<![.?!])[\"”]\n"
+ " |[^\".?!]+\n"
+ " )+)[.?!][\"”]?\n"
+ ")\n"
+ "\\K\\s*";
final String string = "\"This is,\" she said, \"a bad idea.\"\n"
+ "“Beer. Whatever you’ve got on draft is fine.” He handed my a bottle. I didn't want that.\n\n";
final String subst = "\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}