using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<span class=\""select\""[\w\d\s\""=<>:./]*><a href=[\w\d\s\""<>:/.-]+</a></span>";
string input = @"<span class=""select"" foo=""1<>/""><a href=""https://www.domain.tld"">Word 1</a></span><span class=""select""><a href=""https://www.domain.tld"">Word 2</a></span><span class=""no_select""><a href=""https://www.domain.tld"">Word 3</a></span><span class=""select"" bar=""2""><a href=""https://www.domain.tld"">Word 4</a></span>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}