use strict;
my $str = '<span class="select" foo="1<>/"><a href="https://www.domain.tld">Word 1</a></span><span class="select"><a href="https://www.domain.tld">Word 2</a></span><span class="no_select"><a href="https://www.domain.tld">Word 3</a></span><span class="select" bar="2"><a href="https://www.domain.tld">Word 4</a></span>';
my $regex = qr/<span class=\"select\"[\w\d\s\"=<>:./]*><a href=[\w\d\s\"<>:/.-]+</a></span>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}