import re
regex = re.compile(r"<span class=\"select\"[\w\d\s\"=<>:./]*><a href=[\w\d\s\"<>:/.-]+</a></span>", flags=re.MULTILINE)
test_str = "<span class=\"select\" foo=\"1<>/\"><a href=\"https://www.domain.tld\">Word 1</a></span><span class=\"select\"><a href=\"https://www.domain.tld\">Word 2</a></span><span class=\"no_select\"><a href=\"https://www.domain.tld\">Word 3</a></span><span class=\"select\" bar=\"2\"><a href=\"https://www.domain.tld\">Word 4</a></span>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")