re = /<span class=\"select\"[\w\d\s\"=<>:.\/]*><a href=[\w\d\s\"<>:\/.-]+<\/a><\/span>/m
str = '<span class="select" foo="1<>/"><a href="https://www.domain.tld">Word 1</a></span><span class="select"><a href="https://www.domain.tld">Word 2</a></span><span class="no_select"><a href="https://www.domain.tld">Word 3</a></span><span class="select" bar="2"><a href="https://www.domain.tld">Word 4</a></span>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end