import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ":\\s*\\b([\\w-]+\\b(?:\\s+and\\s+\\b[\\w-]+)*)\\b";
final String string = "Product: TLD-1433 infusion Therapy\n"
+ "Biological: CG0070|Other: n-dodecyl-B-D-maltoside\n"
+ "Drug: Atezolizumab\n"
+ "Drug: N-803 and BCG|Drug: N-803\n"
+ "Drug: Everolimus and Intravesical Gemcitabine\n"
+ "Drug: Association atezolizumab + BDB001 + RT|Drug: Association atezolizumab + BDB001+ RT\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}