// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m):\s*\b([\w-]+\b(?:\s+and\s+\b[\w-]+)*)\b").unwrap();
let string = "Product: TLD-1433 infusion Therapy
Biological: CG0070|Other: n-dodecyl-B-D-maltoside
Drug: Atezolizumab
Drug: N-803 and BCG|Drug: N-803
Drug: Everolimus and Intravesical Gemcitabine
Drug: Association atezolizumab + BDB001 + RT|Drug: Association atezolizumab + BDB001+ RT
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}