# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r":\s*\b([\w-]+\b(?:\s+and\s+\b[\w-]+)*)\b"
test_str = ("Product: TLD-1433 infusion Therapy\n"
"Biological: CG0070|Other: n-dodecyl-B-D-maltoside\n"
"Drug: Atezolizumab\n"
"Drug: N-803 and BCG|Drug: N-803\n"
"Drug: Everolimus and Intravesical Gemcitabine\n"
"Drug: Association atezolizumab + BDB001 + RT|Drug: Association atezolizumab + BDB001+ RT\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.