const regex = /:\s*\b([\w-]+\b(?:\s+and\s+\b[\w-]+)*)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(':\\s*\\b([\\w-]+\\b(?:\\s+and\\s+\\b[\\w-]+)*)\\b', 'gm')
const str = `Product: TLD-1433 infusion Therapy
Biological: CG0070|Other: n-dodecyl-B-D-maltoside
Drug: Atezolizumab
Drug: N-803 and BCG|Drug: N-803
Drug: Everolimus and Intravesical Gemcitabine
Drug: Association atezolizumab + BDB001 + RT|Drug: Association atezolizumab + BDB001+ RT
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}