import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^' \"\\n]+)\\.([^ \\n]+)&((?![\"'])[^ \"'\\n])+($|(?=\\s))";
final String string = "google.com/cool?cool1=yes&cool2=no&cool3=no\"\n\n"
+ "google.com/cool?cool1=yes&cool2=no&cool3=no\n\n"
+ "url.com¶meter url2.com¶meter";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}