re = /([^' "\n]+)\.([^ \n]+)&((?!["'])[^ "'\n])+($|(?=\s))/m
str = 'google.com/cool?cool1=yes&cool2=no&cool3=no"
google.com/cool?cool1=yes&cool2=no&cool3=no
url.com¶meter url2.com¶meter'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end