$re = '/([^\' "\n]+)\.([^ \n]+)&((?!["\'])[^ "\'\n])+($|(?=\s))/m';
$str = 'google.com/cool?cool1=yes&cool2=no&cool3=no"
google.com/cool?cool1=yes&cool2=no&cool3=no
url.com¶meter url2.com¶meter';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);